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Who Should Use This Document
This User Guide helps you quickly develop, test, and distribute ZBI programs using 
ZBI-Developer™.

How This Document Is Organized
The User Guide is set up as follows:

Section Description

Introduction An introduction to ZBI-Developer

Installation How to install the program

Interface Reference  Describes the ZBI-Developer interface

Configuration of ZBI-Developer  How to set up and customize software to your 
preferences

Tutorial How to create, test, and distribute a new ZBI 
programs using the ZBI-Developer environment

Encryption of  ZBI™ Programs  How to optionally encrypt programs before 
distributing them

Technical Support  How to contact technical support
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Contacts
You can contact Zebra Technologies Corporation at the following:

Web Site

http://www.zebra.com

Technical Support via the Internet is available 24 hours per day, 365 days per year. Go to 
http://www.zebra.com/support.

The Americas

Europe, Africa, Middle East, and India

Asia Pacific

Regional Headquarters Technical Support Customer Service Dept.

Zebra Technologies International, 
LLC
333 Corporate Woods Parkway
Vernon Hills, Illinois 60061.3109 
U.S.A
T: +1 847 793 2600
Toll-free +1 800 423 0422
F: +1 847 913 8766

T: +1 877 ASK ZEBRA (275 9327)
F: +1 847 913 2578
Hardware: ts1@zebra.com
Software: ts3@zebra.com

For printers, parts, media, and ribbon, 
please call your distributor, or 
contact us.
T: +1 877 ASK ZEBRA (275 9327)
E: clientcare@zebra.com

Regional Headquarters Technical Support Internal Sales Dept.

Zebra Technologies Europe Limited
Zebra House
The Valley Centre, Gordon Road
High Wycombe
Buckinghamshire, HP13 6EQ, UK
T: +44 (0)1494 472872
F: +44 (0) 1494 450103

T: +44 (0) 1494 768298
F: +44 (0) 1494 768210
Germany: Tsgermany@zebra.com
France: Tsfrance@zebra.com
Spain/Portugal: Tsspain@zebra.com
All other areas: Tseurope@zebra.com

For printers, parts, media, and ribbon, 
please call your distributor, or 
contact us.
T: +44 (0) 1494 768316
F: +44 (0) 1494 768244
E: cseurope@zebra.com

Regional Headquarters Technical Support Customer Service

Zebra Technologies Asia Pacific, LLC
120 Robinson Road
#06-01 Parakou Building
Singapore 068913
T: +65 6858 0722
F: +65 6885 0838

T: +65 6858 0722
F: +65 6885 0838
E: China: tschina@zebra.com
All other areas:
tsasiapacific@zebra.com

For printers, parts, media, and ribbon, 
please call your distributor, or 
contact us.
T: +65 6858 0722
F: +65 6885 0836

www.zebra.com
http://www.zebra.com/support
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Document Conventions
The following conventions are used throughout this document to convey certain information.

Alternate Color  (online only) Cross-references contain hot links to other sections in this 
guide. If you are viewing this guide online in .pdf format, you can click the cross-reference 
(blue text) to jump directly to its location. 

Command Line Examples  Command line examples appear in Courier New font. For 
example, type ZTools to get to the Post-Install scripts in the bin directory.

Files and Directories  File names and directories appear in Courier New font. For 
example, the Zebra<version number>.tar file and the /root directory.

Notes and Examples  

Note • Indicates neutral or positive information that emphasizes or supplements important 
points of the main text.

Example • Provides an example, often a scenario, to better clarify a section of text.
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Related Documents
The following documents might be helpful references:

Applicable Zebra Printer User Guide

ZPL II® Programming Guide

ZebraNet® 10/100 Print Server User Guide 

ZebraNet® Wireless Print Server User Guide
1/17/08 ZBI-Developer User Guide 48789L-001 Rev. A
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Introduction - Welcome to ZBI-Developer
ZBI-Developer is an Integrated Development Environment (IDE), designed to assist in the 
creation, testing and distribution of programs written for use in the Zebra Basic Interpreter™ 
(ZBI™). 

ZBI-Developer offers several ease-of-use features:

• Project File Control – Keeps related files in a single Project folder

• Pop-up Help – displays ZBI command syntax and examples 

• Virtual Printers – allows ZBI programs to be run on the PC, with no need for a printer 

• Multiple Perspectives – displays different display modes for the software:

• ZBI Perspective – used for writing ZBI programs

• Debug Perspective – used for testing and checking programs

• Multiple Views – displays different information screens:

• Navigator View – used to manage Projects and files in projects

• Printer View – used to manage physical and virtual printers

• Debug View – used to display the name of the program being tested

• Breakpoints View – used to view the list of breakpoints and jump to each point 

• Variable View – used to view the current value of variables in the program

• Problems View – displays Warnings and Errors detected in the ZBI program

• Ports View – displays data as it flows through ports used in the program

• Program Distribution – programs can be easily sent to a printer

• Program Encryption – programs can be encrypted in order to protect proprietary data

• File Drag and Drop – files can be dragged into a project from the Windows® Explorer 
environment

• File Import – files can be imported from printers into Projects in ZBI-Developer

• File Compare – files can be compared to earlier versions of the same file or to other files
1/17/08 ZBI-Developer User Guide 48789L-001 Rev. A
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System Requirements

These are the minimum requirements needed to run ZBI-Developer™

• Pentium®-based computer with at least 64 MB of RAM

• One of the 32-bit Windows® operating system: 

• Windows 2000®

• Windows XP®

• Windows Vista®

• Windows Server 2003®

• Hard disk with 80 MB of free disk space

• Administrator rights to the local computer during installation

Printers, ZBI Keys & ZBI Versions

Information about ZBI 1.x and ZBI 2.x:

ZBI versions 1.0 through 1.5:  

ZBI 1.x was available on printers with X.10 or higher firmware (such as V48.10.x). To 
determine if the printer supports ZBI version 1, check the firmware version loaded on the 
printer. This can be determined by the absence of a “Z” in the firmware version number (for 
example, firmware V60.13.0.12 supports ZBI version 1, while V60.13.0.12Z does not). The 
following printers support the ZBI 1.x firmware:

• LP/TLP 284x-Z and 384x-Z

• S300/S400/S500/S600

• Z4000/Z6000

• Z4M/Z6M

• Z4Mplus/Z6Mplus

• 105SL

• PAX3

• XiII

• XiIII

ZBI-Developer can be used to create programs for use on printers that support ZBI version 
1.x., however, the features that are only available in ZBI v2.x cannot be used with printers 
running ZBI v1.x. For example, “on-printer” debugging advanced file encryption and 
commands added in ZBI 2 are not supported in printers running ZBI 1.x. If you do not have a 
printer that meets this requirement, contact your reseller.

Note • Support for ZBI versions 1.0 through 1.5 is limited to syntax checking only. 
On-printer debugging is not supported for ZBI versions 1.0 through 1.5.
48789L-001 Rev. A ZBI-Developer User Guide 1/17/08
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ZBI versions 2.0 and higher:  

Printers with firmware versions X.16 or later (for example, V60.16.x and V53.16.x) can 
support ZBI version 2.0 and later. The following printers support the ZBI 2.x firmware:

• XiIII Plus

• Z4Mplus/Z6Mplus

• 105SL

• S4M

• PAX4

• ZM400/ZM600

These printers can be either ZBI-Ready or ZBI-Enabled, depending on whether or not a ZBI 
Key file has been loaded on the printer. ZBI Keys can be loaded onto printers during 
manufacturing or later purchased at www.zebrasoftware.com. A Downloader Utility/ZBI Key 
Manager software utility is available to assist in the task of sending ZBI Keys to printers.

The ZBI.nrd file is required to be present on the printer for ZBI 2.0 to be enabled. The ZBI 
Key is stored on the printer’s E: memory location with the name ZBI.nrd. The file is persistent. 
It cannot be deleted even if the printer’s memory is initialized. For example, if the ^JB 
command is used to initialize the location, the ZBI Key file will not be deleted.

When a printer is ZBI-Ready but not ZBI-Enabled, the firmware version will display a "Z" at 
the end of the version string (for example, V60.16.0Z). Additionally, the printer’s 
configuration label will show that the printer is not ZBI-Enabled.

When a printer is ZBI-Enabled, the firmware version will not display a "Z" at the end of the 
version string (for example, V60.16.0). Additionally, the printer’s configuration label will 
show that the printer is ZBI-Enabled.

Note • Each single ZBI Key can only be used once. When multiple printers are to be 
ZBI-Enabled, multiple Keys will be needed. The ZBI Key cannot be retrieved from printer 
to a host system.

Supported Print Servers

These are the supported ZebraNet print servers:

• ZebraNet 10/100 Print Server (firmware V1.1.6 required to support on-printer debugging)

• ZebraNet Wireless Print Server (V60.16.x, V53.16.x or later firmware required)

• ZebraNet Wireless Plus Print Server (V60.16.x, V53.16.x or later firmware required)
1/17/08 ZBI-Developer User Guide 48789L-001 Rev. A



ZBI-Developer
Installation

16
Installation
ZBI-Developer can be installed from a downloaded copy or from a CD-ROM containing the 
software. Before starting the ZBI-Developer installation, close all other software applications. 
This ensures a complete installation of all of the program files. 

The complete installation package can be downloaded from www.zebra.com 

Note • If you are using Windows 2000, Windows XP, Windows Vista or Windows Server 
2003, you must log on with Administrator rights to perform the installation.

During the installation, follow the user prompts to control the location in which to install the 
software and other options. If you change the default directory location for the software 
installation, be sure to note the new location. This information will be helpful to have for 
backup and archival purposes. 

Once the installation is complete, click Finish to complete. 
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Starting ZBI-Developer

ZBI-Developer can be started from the Windows Start menu – Start > Programs > 
ZBI-Developer or from any shortcuts created for the ZbiDeveloper.exe file.

When the program is run for the first time, the default interface, or workspace, will be 
displayed.
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The Interface
The ZBI-Developer interface is designed to give the user quick access to the key features 
needed to develop ZBI programs. The interface is divided into various visual elements; these 
include the Menu bar, Toolbars, Perspectives, Views, and Editors that make up the interface.

• Menu and Toolbars – display quick access to the various functions and features of 
ZBI-Developer

• Projects – used to manage the files associated with creating a ZBI program

• Perspectives – display different use modes for the software:

• ZBI Perspective for writing ZBI programs

• Debug Perspective for testing and checking programs. 

• Views – display different information screens:

• Navigator View – used to manage Projects and files in projects

• Printer View – used to manage physical and virtual printers

• Debug View – used to display the name of the program being tested

• Breakpoints View – used to view the list of breakpoints and jump to each point 

• Variable View – used to view the current value of variables in the program

• Problems View – displays Warnings and Errors detected in the ZBI program

• Ports View – displays data as it flows through ports (serial, parallel, IP) used in a ZBI 
program

Editors – Used to create and alter files. The appropriate editor is displayed for the selected file 
type.
48789L-001 Rev. A ZBI-Developer User Guide 1/17/08



19ZBI-Developer
The Interface
Menu and Toolbars

The Menu and Toolbars are located at the top of the screen. They provide access to the File, 
Edit, Run, Window, and Help submenus and commonly used program features.

File Menu

The File menu enables you to create, save, close, print, import, and export resources, and exit 
ZBI-Developer.

 New Project

To create a new Project, select File > New > New Project. 

The New ZBI Project Wizard will display, with prompts for creating a new Project. Use the 
Wizard prompts to fill in the Project name (required). Click Finish to complete the Wizard.
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 New Folder

To create a new Folder within a Project, click on a Project in the Navigator View to select it 
and click File > New > New Folder. 

The New Folder Wizard will display, with prompts for creating the New Folder. Use the 
Wizards prompt to fill in the New Folder name. Click Finish to complete the Wizard. 
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New ZBI Program

To create a new ZBI Program, select File > New > New ZBI Program. A new, Untitled ZBI 
program will open and display in the ZBI-Developer workspace. The program will not appear 
in the Project Folders until it is named and saved. To Save and Name a program, type or paste 
content into the program and click the File > Save menu selection.

New Untitled File

To create a new Untitled File, select File > New > New Untitled File. Untitled Files are 
usually created to store data important to the Project, such as data or input streams that the ZBI 
program will use during execution. Untitled Files can also be used to create Notes or 
documentation for the Project. Clicking the New Untitled File icon has the same effect. A new, 
Untitled File will open and display in the ZBI-Developer workspace. The File will not appear 
in the Project Folders until it is named and saved. To Save and Name a program, type or paste 
content into the program and click the File > Save menu item. 
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 Import a File

To Import a file from the computer’s hard drive into a Project, select File > Import…. Files 
cannot be imported unless they are being directed into a Project. 

When Import… is selected, the Import Wizard will be displayed. Use the Browse button to 
select the file to import. Use the Name to Import As textbox to alter the name as needed. Files 
with .zbi extensions will be imported as .zbi files. Other file types will retain their original file 
extension. If a file does not have an extension, it will be given a .txt extension.
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To Export ZBI Programs and Encryption Key Files from the ZBI-Developer environment to 
the computer’s hard drive, click on a file and then select File > Export….

Based on the choices entered in the Export Wizard, the name of the file and the printer 
memory location to store it in will be written automatically into the Export file.

The purpose of the Export ZBI Program feature is to create a file that can be distributed to one 
or more printers. During the Export process, ZBI programs will be exported in a format for use 
on a printer. The program will be MIME encoded, with all REM statements removed from the 
program. 

Note: In order for an encrypted program to be executable, the matching encryption key 
must also be present in the printer. 

If the ZBI program has been Encrypted, then the Exported file will be Encrypted and MIME 
encoded. This allows the programmer to create a file that can be emailed to users without 
revealing proprietary information.
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Exporting Projects

To Export a ZBI Project to a single file on the computers hard drive, click on a Project folder 
and then select File> Export… 

Based on the choices entered in the Export Wizard, the files in the project will be written to a 
single file on the hard drive. 

The purpose of the Export feature is to create a file that can be distributed to one or more 
printers. During the Export process, ZBI programs will be exported in a format for use on a 
printer. The program will be MIME encoded, with all REM statements removed from the 
program.

If the ZBI program has been Encrypted, then the Exported file will be Encrypted and MIME 
encoded. This allows the programmer to create a file that can be emailed to users without 
revealing proprietary information. To use this feature, it is necessary to first use the Export 
Encryption Key feature
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The Encryption Key can be Exported and then sent to the printer. This feature allows for the 
following scenario – a Developer can create a ZBI program and then encrypt it. The 
Encryption Key can then be downloaded to the printer – thus allowing later updates of the 
program to also be downloaded to the printer. In this way, the Developer can protect their 
source code, while also allowing for program updates. 

To Export a ZBI Encryption Key to a single file on the computers hard drive, click on a 
Encryption Key file and then select File> Export… 

Based on the choices entered in the Export Wizard, the Encryption Key will be written to a 
single file on the hard drive. 

The exported file can now be sent to printers as needed.

Note • The Encryption Key must be installed on the printer by the programmer so as to 
maintain control over the ability to put the Encrypted programs on printers. The Key 
should not be distributed to end users.

Close

The Close menu selection will close the currently selected file.

Close All

The Close All menu selection closes all currently open files.
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 Save

The Save menu selection will Save the currently selected file. If the file has a .zbi extension, it 
will be saved as a ZBI program. If the file is an Untitled File, it will be necessary to give the 
file an extension when saving it. 

In all cases, if multiple Projects exist, it is necessary to specify which Project to save the file 
in. 

The program will display “Invalid File Name” if no name is entered or if the “.” character is 
used but no extension is entered.

Note • ZBI-Developer will attempt to make use of the file extension associations currently 
in use in the operating system. This means that if a file is saved as a .doc file, ZBI-
Developer will attempt to call the file viewer associated with that file type.

 Save As

The Save As menu selection will Save the currently selected file with the opportunity to 
rename the file, change the file’s extension, and alter the Project directory the file is stored in. 

If the file has a .zbi extension, it will be saved as a ZBI program. If the file is an Untitled File, 
it will be necessary to give the file an extension when saving it. The program will display 
“Invalid File Name” if no name is entered or if the “.” (period) character is used, but no 
extension is entered. 

In all cases, if multiple Projects exist, it is necessary to specify which Project to save the file 
in.

Note • ZBI-Developer will attempt to make use of the file extension associations currently 
in use in the operating system. This means that if a file is saved as a .doc file, ZBI-
Developer will attempt to call the file viewer associated with that file type.

 Save All

The Save All menu selection will close all currently open files. If the file has a .zbi extension, 
it will be saved as a ZBI program. If the file is an Untitled File, it will be necessary to give the 
file an extension when saving it. The program will display “Invalid File Name” if no name is 
entered or if the “.” (period) character is used but no extension is entered. 

In all cases, if multiple Projects exist, it is necessary to specify which Project to save 
previously unsaved files in.

Note • ZBI-Developer will attempt to make use of the file extension associations currently 
in use in the operating system. This means that if a file is saved as a .doc file, ZBI-
Developer will later attempt to call the file viewer associated with that file type.
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Revert

Choosing Revert will alter the content of the current Editor back to the content of the last 
saved file. The Revert menu choice is disabled if the editor does not contain any unsaved 
changes.

Note • Do not confuse Revert with Undo. The Undo feature reverses you most recent 
editing action, while Revert returns the contents of the editing window to the saved 
contents of the file.

Rename

Rename allows the user to alter the name of a previously created Project or a file within a 
Project. A Folder or File must be selected for the Rename menu selection to be active. Only 
one Project or File can be renamed at a time. 

 Print

Print allows the currently selected and open file to be printed.

Exit

Selecting Exit closes all open files. The program will confirm if recent unsaved changes 
should be saved. 

Edit Menu

The Edit menu helps you alter, search, and manage files in the ZBI-Developer editor 
environments.

 Undo

This command will reverse the most recent edit.

 Redo

The Redo feature will re-apply the last edit that was reversed by the most recent Undo action. 

 Cut

Removes the selected text and places it on the clipboard.

 Copy

Copies the selected text to the clipboard.
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 Paste

Places the text currently on the clipboard in the open document at current cursor location.

 Delete

Removes the currently selected item.

Note • The Delete feature can remove selected text, or an object such as a file or an entire 
Project.

Select All

Selects all objects or text in the current view or editor. 

Find/Replace 

The Find feature is used to search the current editor for an expression. The optional Replace 
feature allows the user to replace an expression with another expression.

Find Next

Allows the user to search for the next occurrence of the selected text or the next occurrence of 
the most recently found expression. 

Find Previous

Allows the user to search for the previous occurrence of the selected text or the previous 
occurrence of the most recently found expression. 
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Word Completion 

This feature is offered when editing text files. When selected, it will attempt to complete the 
current word.

Set Encoding 

This feature is offered when viewing text and other files that are not ZBI programs. The 
following encoding types can be set:

• Codepage1252 (Cp1252)

• US-ASCII

• UTF-16

• UTF-16BE

• UTF-16LE

• UTF-8

• ISO-8859-1

To set or change the encoding type, right-click over a file and open the Properties dialog.
1/17/08 ZBI-Developer User Guide 48789L-001 Rev. A



ZBI-Developer
The Interface

30
Run Menu

Run\Debug ZBI Application 

This feature will cause ZBI-Developer to execute the selected ZBI program on the Connected 
printer. If no printer connection has been created, the program will display an Error dialog 
stating “No Connection. Please connect to a Printer”. 

Window Menu

The Window > Show Perspective and > Show View menus are used to change the current 
View, Perspective, and access the Preferences dialog. 

A Perspective defines the set and arrangement of Views and dialogs shown in the 
ZBI-Developer workspace. Within the window, each Perspective shares the same set of 
editors. 

Each Perspective provides a set of features and functions aimed at accomplishing a specific 
task. For example, the ZBI Perspective combines Views that you would commonly use while 
editing ZBI project source files. The Debug Perspective contains the Views that you would 
use while debugging programs. As you work in the program, you will probably switch the 
Perspective frequently.

There are two Perspectives in the program, ZBI and Debug. 
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ZBI Perspective
The ZBI Perspective is used to create ZBI Projects and the actual ZBI program. By using the 
features of Navigator View, Printer View, Problems View and Editor View, the 
programmer will be able to quickly create a ZBI program.
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Navigator View

This View displays the list of file and objects associated with Projects. The Navigator View is 
the primary location for managing the items used in a project. 

A Project in the Navigator View can be open or closed by right-clicking over the Project and 
selecting the desired action. 

Additionally, actions from the File menu are also available by right-clicking on the Navigator 
view. The Properties for a Project can also be accessed by right-clicking over a Project name. 
48789L-001 Rev. A ZBI-Developer User Guide 1/17/08



33ZBI-Developer
ZBI Perspective
Printer View

This View displays the list of printers available for use with Projects. The Printer View is the 
primary location for managing the Printers that will be used with ZBI-Developer.

Printers can be connected directly via serial or parallel ports, or a ZebraLink network interface, 
such as a ZebraNet 10/100 Wired or Wireless print server. 

When printers are connected to the PC via a serial, parallel, USB or ZebraLink Ethernet 
interface, a Debug connection can be made to the printer. This feature allows programs to be 
run in the Debug mode, and allows the output of the ZBI programs to be sent directly to the 
printer. 

Virtual Printers can also be created so that programs can be run in the Virtual ZBI 
environment. When a Virtual Printer is used, the output of the program can be directed to a PC 
Comm Window that displays in the Debug View, or the output can be directed to a serial or 
parallel port on the PC. 
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Create a Virtual Printer

ZBI-Developer comes with a Virtual Printer pre-installed. Additional Virtual Printers can be 
defined by right-clicking over the Virtual Printer folder and selecting Add Virtual Printer.

The Add Virtual Printer Wizard will be displayed. Enter a Printer name in the textbox. The 
name can be up to 100 characters long.
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Configure where output from the Virtual Printers ports should be directed. Since the printer is 
Virtual, output can be redirected to one of several locations. For example, if the ZBI program 
directs that the output should go to a serial port (SER in ZBI commands), the Virtual Printer 
can redirect that output to a Ports View dialog in the Debug Perspective, or to a physical port 
on the computer.

Using this method, a ZBI program could logically send output to a serial port (SER in ZBI 
command), but that data could be redirected to a parallel port on the PC. In this way, it is 
possible to test the output of a ZBI program on a printer when a ZBI-Enabled printer is not 
available. 

Additionally, output could be redirected to a Ports View dialog on the PC instead of to a 
physical communication port. Using this method a ZBI program can be created and tested 
when no printer is available.

Note • Virtual Printers can be used to examine the output of a ZBI program. They do not 
have the ability to create an image of a printed label based on the receipt of printer 
commands. That capability is only present in the printer.
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Edit a Virtual Printer

Virtual Printers can be easily edited to alter their settings. To Edit a Virtual Printer, 
right-click over the Virtual Printer in the Printers View and select Edit Virtual Printer.

The Edit Virtual Printer Wizard will display.
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Configure where output from the Virtual Printers ports should be directed. Since the printer is 
Virtual, output can be redirected to one of several locations. For example, if the ZBI program 
directs that the output should go to a parallel port (PAR in ZBI commands), the Virtual Printer 
can redirect that output to a Ports View dialog in the Debug Perspective, or to a physical port 
on the computer.

Using this method, a ZBI program could logically send output to a parallel port (PAR in ZBI 
command), but that data could be redirected to a serial port on the PC. In this way, it is 
possible to test the output of a ZBI program on a printer when a ZBI-Enabled printer is not 
available. 

Additionally, output could be redirected to a Ports View dialog on the PC instead of to a 
physical communication port. Using this method, a ZBI program can be created and tested 
when no printer is available.

Note • Virtual Printers can be used to examine the output of a ZBI program. They do not 
have the ability to create an image of a printed label based on the receipt of printer 
commands. That capability is only present in the printer. 
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Using Virtual Printers

The figure below illustrates the testing of a simple ZBI program using a Virtual Printer. 

In this case, the ZBI program receives data from the Serial port and sends output to the ZPL 
print engine in the printer. The Virtual printer is configured to display both the Serial port input 
and ZPL port output in Ports View dialogs. A Breakpoint has been set to cause the program to 
display the value of the A$ input variable in the Variable View dialog.

Note • When using the Debug Perspective, ZBI-Developer can be occupied while it is 
executing the program. If you are done using the Debug Perspective, be sure to click 
Terminate.
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Problems View

This View displays the list of Warnings and Errors the software has identified in the ZBI 
programs in all open Projects. If a project is closed, ZBI-Developer will not display Problems 
for the project. Only files with a ".zbi" extension will be checked for issues. 

The Problems View uses plain language to inform the user of Warnings and Errors that 
ZBI-Developer has identified in a ZBI programs. Double-clicking on an error will cause the 
program to automatically highlight the line in the ZBI program that has been identified. If the 
program is closed, it will be opened in the ZBI Editor. 

ZBI programs that contain Warnings and Errors can still be run on a Virtual Printer, tested 
in the Debug Perspective, or sent to a printer. The Problems View exists only to inform about 
issues, not to stop users from writing and using programming techniques. 
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Debug Perspective
The Debug Perspective is used to execute a ZBI program, either with a physical printer, or 
with a Virtual Printer. By using the Debug View, the programmer can quickly test the logic and 
flow of their ZBI program. 

There are several key Views in the Debug Perspective. 
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Debug View
The Debug View displays the name of the program being tested.

Note • When using the Debug Perspective, ZBI-Developer can be occupied while it is 
executing the program. If you are done using the Debug Perspective, be sure to click 
Terminate.

Button Description

The Run/Debug Application button (located in the Toolbar) begins the execution of the 
program. 

The Pause button (located on the Debug View) suspends the execution of the program so that 
the user can browse the program, check the printer, examine the Variable View, etc. 

The Terminate button halts the execution of the program.

The Step Over button steps over a set breakpoint. Program execution will continue on the 
next line.

The Resume button resumes a paused program execution.
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Variable View

Displays the variables currently present in a ZBI program during execution in the Debug 
View.

The Variable View makes it simple to identify the contents of the variables in your program. 
When combined with the Port Views and carefully set breakpoints, the programmer can type 
information in and immediately see how data is being populated into variables in a program.

Note • In some cases, Variables may not appear in the Variable View. This can happen 
when no Breakpoints have been set in the program. Be sure to set Breakpoints to make the 
best use of the Variable View feature.
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Breakpoints View

Displays the Breakpoint set in a currently running ZBI program. To set a Breakpoint in the ZBI 
program, right-click immediately to the left of a line of ZBI code and choose Toggle 
Breakpoint. 

Enabled breakpoints are noted with a blue circle . Disabled breakpoints are noted with a 
white circle . Breakpoints are displayed in the vertical editor ruler and in the Breakpoints 
View.

A breakpoint suspends the execution of a program at the location where the breakpoint is set. 
In the ZBI Editor, breakpoints can be enabled and disabled by using the displayed 
checkboxes. Double-clicking on a breakpoint in the Breakpoints View will highlight it in the 
ZBI Editor. 

Note • The maximum number of breakpoints per program is 16.

Help Menu

 Update

This menu selection causes ZBI-Developer to contact the web-based program update service 
and obtain the most recent update. The program will not be updated if it is the most current 
version. Follow the prompts to complete the update. 
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View ASCII Table

Causes an ASCII chart to be displayed as shown below. Scroll on the chart to view desired 
character(s). 
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About ZBI-Developer

Causes the About ZBI-Developer dialog to display.
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Configuration of ZBI-Developer
This section describes you how to set up and customize ZBI-Developer to your preferences.

Changing the Workspace Location

By default, ZBI-Developer stores its files in a Workspace folder, or directory on the PC it is 
being used on. Knowing where this directory is makes it possible to ensure that the directory is 
being backed on a regular basis (a recommended practice!). 

Additionally, for some work-groups, it may be desirable to maintain the Workspaces of several 
ZBI Developers on networked server rather than on local drives. This practice is also 
encouraged, especially if it means that the Workspace directories will be regularly archived

To change the Workspace location, go to File menu and select File > Switch Workspace. The 
Workspace Launch wizard will display, showing the current location of the workspace. Click 
on the Browse button to navigate to and define the new location to store the Workspace in. 

Note • Once a new Workspace location has been defined, ZBI-Developer will take a few 
moments to move the necessary files and restart itself. You will see the start-up splash 
screen as the program restarts.
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Setting Preferences

There are four types of Preferences to configure for ZBI-Developer. To begin setting 
Preferences, select Window > Preferences. When the Preferences dialog appears, click on the 
"+" symbol next to ZBI Preferences to expand the list. 

Email Options

The Email Options control the settings used to send email from ZBI Programs when a Virtual 
Printer is being used. Enter a Server Name specific to the site the program will be used in and 
set the Port to use as needed. Port 25 is the default port used for Email. 

Encryption Key

This dialog controls the location and name of the Encryption Key ZBI-Developer will use 
when the user chooses to use the optional ZBI program Encryption feature. 

Note • It is recommended that one key be used for entire company or development group. 
While it is possible to create multiple keys (i.e., one for each project, or one for every 
developer in a given company, this is not recommended to decrease the possibility of lost 
keys.

Saved Searches

In some cases, the desired printer may not be automatically discovered. This can happen 
because the printer is on a different subnet, or because traffic on the network is being 
controlled in such a way that the discovery process is not allowed to complete. Many times, 
what is needed is a different type of search. 

ZBI-Developer offers five types of network searches:

• Local Broadcast Search

• Subnet Search

• Directed Broadcast Search

• Multicast Search

• IP Address Search

Note • The connection to a networked printer can be tested by right-clicking over the 
printer in the Printers View and choosing Print Configuration label. If the connection is 
active, a configuration label should print.
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To set up a search for a network printer, do the following:

1. Go to the menu and choose Window > Preferences. The Preferences dialog will be 
displayed. 

2. Click on the "+" symbol next to ZBI-Preferences.

3.  Click on Saved Searches. 

4. Then, click on New Search. 

Local Broadcast Search

Local broadcasts send a discovery request to the local broadcast address of 255.255.255.255. 
This request finds printers in the same local network as the requesting computer. The local 
broadcast search is the default search type used by the program. 

To create a local broadcast search, do the following:

1. In the Search Type dialog, select Local Broadcast. The Value fields are automatically 
populated. 

2. Type a name in the Search Group Name textbox.
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3. Click Add. The Value field is added to Search type. 

4. Click OK to accept the new Search Type.

5. Click OK to exit the Preferences dialog.

Subnet Search

The Subnet Search sends a discovery request to each address in the specified subnet. This 
feature is useful for networks that prevent broadcast packets from passing across routers. The 
Subnet search requires you to type in the first three subnet octets. 

Example • A request to 192.168.2.* sends a request to: 192.168.2.1 through 
192.168.2.254.

To create a Subnet Search, do the following:

1. From the Search Type dialog, select Subnet.

2. Type a name in the Search Group Name textbox.

3. In the Value field, type the first three subnet octets.

4. Click Add.

5. Click OK to accept the new Search Type.

6. Click OK to exit the Preferences dialog.

Directed Broadcast Search

Directed broadcasts send a discovery request to the broadcast address of the specified subnet.

Note • If a broadcast search does not work, the broadcast packets might be disabled across 
routers. Try Multicast or Subnet search.

Example • The directed broadcast search requires you to type in the first three subnet 
octets, followed by 255, such as 192.168.2.255.

To create a Directed Broadcast search, do the following:

1. In the Search Type dialog, select Directed Broadcast. The fourth octet of the Value field 
is automatically populated. 

2. In the Value field, type the first three subnet octets.

3. Type a name in the Search Group Name textbox.

4. Click Add. 

5. Click OK to accept the new Search Type.

6. Click OK to exit the Preferences dialog.
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Multicast Search

Multicast uses the multicast address to send a discovery address to all Zebra printers across as 
many routers as the hop count specifies. A multicast search may return a large number of 
printers in some installations.

this feature might be disabled on some routers and switches. See your network administrator to 
determine if a search failure was due to this feature being disabled. 

To create a multicast search, do the following: 

1. In the Search Type dialog, select Multicast (Hops). 

2. In the Value field, type the number of hops desired. The recommended starting point is 5.

3. Type a name in the Search Group Name textbox.

4. Click Add. 

5. Click OK to accept the new Search Type.

6. Click OK to exit the Preferences dialog.

IP Address Search

To create a search for an IP address, do the following:  

1. In the Search Type dialog, select IP Address xxx.xxx.xxx.xxx.

Example • You would type in an IP address, such as 10.3.4.97.

2. In the Value field, type in an IP address.

3. Type a name in the Search Group Name textbox.

4. Click Add. 

5. Click OK to accept the new Search Type.

6. Click OK to exit the Preferences dialog.

SNMP

The SNMP settings are used to control how ZBI-Developer interacts with a printer when the 
on-printer debugging features are in use. These features are available when a printer running 
firmware v60.16.x and v53.16.x or later are in use. ZBI-Developer will use SNMP commands 
("set" and "get") to activate the debugging features on the printer when the indicated firmware 
versions are being used. The default setting are the recommended settings. 

Note •  Some networks may be configured to not allow SNMP traffic. Please consult with 
your network administrators first if the on-printer debugging features are not working 
when you have successfully connected to a printer. The connection to a networked printer 
can be tested by right-clicking over the printer in the Printers View and choosing Print 
Configuration label. If the connection is active, a configuration label should print. 
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Changing the Screen Layout

The initial screen layout may be appropriate for many uses, however the user may find that the 
layout is not optimized for the project being worked on. The layout of many of the Views can 
be changed to suit the needs of the user. 

To move a View, click and drag it to a new location. It is also possible to right-click over the 
tab for a View and select Move > View. While a View is being moved, an outline of the View 
will be visible. 

Note • For example, the Problems View can be moved or even detached from the main 
window of the program to maximize the space provided for the ZBI Editor View. Here it 
is shown detached from the main window of the program.

To re-attach a detached View, right-click over it and un-select Detached. It will re-join the 
main window of the program. 
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ZBI-Developer Tutorial 
This Tutorial demonstrates creating, testing and distributing a simple ZBI project, using many 
of the key features of ZBI-Developer.

This is the program that will be created:
10 close all
20 open #1: name "SER"
30 open #2: name "ZPL"
40 input #1: A$
50 print #2: "^xa^fo50,50^a0n,50,50^fd"&A$&"^fs^xz"
60 goto 40

In this Tutorial, it will not be necessary to have a ZBI-Enabled printer present. All of the 
activities described here can be performed without a printer present. However, if a ZPL printer 
is available, it will augment the Tutorial if you connect the printer to the serial port of the 
computer running ZBI-Developer.

Some key concepts that this Tutorial covers:

• Views

• Perspectives

Views

The software offers several Views. These are used to display different information screens.

Perspectives

Two modes of operation, or Perspectives, are available in ZBI-Developer

• ZBI Perspective – for writing ZBI programs

• Debug Perspective – for testing and checking programs

Tutorial 
Line 

Number
Line-by-Line Explanation

10 Closes all ZBI Ports

20 Opens a "#1" port and names it "SER"

30 Opens a "#2" port and names it "ZPL"

40 Receives from "#1" port and stores it in the "A$" variable

50 Embed the data stored in "A$" in ZPL commands and prints it

60 Returns to line 40 to look for more input
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Project Files

Projects are used to organize and track files associated with a single or set of ZBI programs. 
Projects can contain several file types:

• ZBI programs – containing up to an 8 character file name and the .zbi extension. ZBI 
programs are displayed with the  icon. 

• Data Files – these can be any file, ASCII or Unicode encoded, that is associated with 
the Project. Data Files are displayed with the  icon. 

• Project Key – the Encryption Key that will be used with the Project. The Project Key 
file is displayed with the  icon. Each Project can have its own Project Key file. 

• Encrypted ZBI program – ZBI programs that have been encrypted are displayed 
with the  icon. An encrypted program can be viewed in plain text in ZBI-
Developer but will be sent to the printer in encrypted form. 

• Project Folders – displayed with the  icon. Project Folders can be copy and 
pasted. 

• Other File Types – Other file types can be viewed in the ZBI-Developer 
environment, as allowed by file associations on the PC being used. Files can also be 
opened using the ZBI-Developer Text Editing environment. For example, a .jpg file 
would open using the default system viewer, unless the ZBI-Developer Text Editor is 
chosen.

Note • It is recommended that Projects and Project files be backed up on a regular basis. 
ZBI-Developer does not automatically back-up files or offer a method for un-encrypting 
programs if the Encryption Key is not present.
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Starting the Software

Navigate to the shortcut icon – Start > Programs > ZBI-Developer. The program’s splash 
screen will be briefly shown as the program starts and then the main interface window will be 
displayed.
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Starting a New Project

To start a new Project, go to File > New > New Project. Alternately, right-click over the 
Navigator View and choose New > New Project.

The New Project Wizard will be displayed. 

Name the Project "My Project" and click Finish.

The new Project will be displayed in the Navigator View.
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Starting a New ZBI Program

Next, start a new ZBI program. Right-click over the "My Project" folder and choose 
New > New ZBI Program. A new, blank ZBI Editor View will be displayed, with the title 
"Untitled 1".
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Saving a New ZBI Program

To save a new blank ZBI Program:

• Go to File > Save As. The Save ZBI Program Wizard will be displayed. 

• Enter a name for the program - "Hello".

• Click the My Project folder to confirm that it is the Project to save the new program in.

• Click Finish. 

Note • It is necessary to click on the Project folder the ZBI program should be saved in. 
This practice helps keep related files together.
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Once the ZBI program has been saved, the new name will appear in the ZBI Editor View. 
Clicking on the "+" next to the My Project folder will cause it to be displayed in the 
Navigator View. 

Writing a New ZBI Program

As the ZBI program is begin written, several features of the software can be used to assist the 
developer. 

These include:

• ZBI Command Syntax Help

• Problems View

• Context Sensitive Help

• Virtual Printers

• Debug View
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ZBI Command Syntax Help

ZBI-Developer can automatically display ZBI syntax command Help by placing the mouse 
cursor over a command in the Editor View.

Write the first line of the program (or copy/paste it from here). 
10 close all

Place the mouse cursor over the word close. After a moment, a dialog will display over the 
Editor showing the correct syntax and usage for the command. This feature can be used with 
all of the ZBI commands.

Note • The ZBI Command Syntax Help will only appear when a file with a ".zbi" file is 
being edited.
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The Problems View

The Problems View displays the list of Warnings and Errors the software has identified in 
the ZBI programs in all open Projects. If a project is closed, ZBI-Developer will not display 
Problems for the project. Files that do not have a .zbi extension will not be checked for issues. 

The Problems View uses plain language to inform the user of Warnings and Errors that 
ZBI-Developer has identified in a ZBI programs. Double-clicking on an error will cause the 
program to automatically highlight the line in the ZBI program that has been identified. If the 
program is closed, it will be opened in the ZBI Editor. 

Complete the new ZBI program by entering the remainder of the program as shown below.

Note •  This content contains intentional errors to help demonstrate a feature of 
ZBI-Developer.

20 open #1: name "SER
30 open #2: name "ZPL
40 input #1: A$
50 print #2: "^xa^fo50,50^a0n,50,50^fd"&A$&"^fs^xz"
60 goto 70

When the program has been entered as shown above, click File > Save to save the file. Once 
the program has been saved, ZBI-Developer will evaluate the program and display Errors or 
Warnings for any lines that contain syntax issues.

Double-clicking on an Error or Warning in the Problems View will cause the portion of the 
program containing the issue to be highlighted in the ZBI Editor View. 
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Once any Errors or Warnings have been corrected, save the program again to remove the items 
listed in the Problems View. For convenience, here is the corrected version of the program:

10 close all
20 open #1: name "SER"
30 open #2: name "ZPL"
40 input #1: A$
50 print #2: "^xa^fo50,50^a0n,50,50^fd"&A$&"^fs^xz"
60 goto 40

Setting Breakpoints

A Breakpoint suspends the execution of a program at the location where the breakpoint is set. 
In the ZBI Editor, breakpoints can be enabled and disabled by using the displayed 
checkboxes. Double-clicking on a breakpoint in the Breakpoints View will highlight it in the 
ZBI Editor. 

To set a breakpoint, right-click immediately to the left of a line of ZBI code and choose Toggle 
Breakpoint. In the case of the example program in this tutorial, put the Breakpoint on line 60. 
When the program is executed, the printer will stop each time it reaches that line. 

Note • The maximum number of breakpoints per program is 16.

Note • When a program containing breakpoints is sent to the printer, the breakpoints will 
also be transmitted–meaning that the program will stop whenever a breakpoint is reached. 
To avoid this situation, remove breakpoints before sending programs to printers. It is 
possible to remove all of the Breakpoints in the file by clicking on the  icon in the 
Breakpoints View dialog.
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Discovering Printers

Once a program is written and ready to be tested, it can be run on a printer – or run in the 
Virtual Printer environment. 

If a physical printer is to be used, it will be necessary to first Discover and connect to a printer. 
ZBI-Developer supports using printers connected to a network using a ZebraNet print server. 
If a printer is connected via serial or parallel connection, a Virtual Printer should be used and 
data should be redirected to the port on the PC that the printer is connected to. (See Using 
Virtual Printers on page 66 for more details.) 

If the printer is connected to the same network subnet that the PC running ZBI-Developer is 
attached to, then a list of available printers will appear on the Printer View tab. 

Once a printer has been discovered, it can be used to Create a Debug Connection, Run/
Debug a Program, Send Files to a Printer or Import Files From a Printer.

Setting Up Searches

In some cases, the desired printer may not be automatically discovered. This can happen 
because the printer is on a different subnet, or because traffic on the network is being 
controlled in such a way that the discovery process is not allowed to complete. Many times, 
what is needed is a different type of search. 

ZBI-Developer offers five types of network searches:

• Local Broadcast Search

• Subnet Search

• Directed Broadcast Search

• Multicast Search

• IP Address Search

Note • The connection to a networked printer can be tested by right-clicking over the 
printer in the Printer View and choosing Print Configuration label. If the connection is 
active, a configuration label should print.
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To set up a search for a network printer, do the following:

1. Go to the menu and choose Window > Preferences. The Preferences dialog will be 
displayed. 

2. Click on the "+" symbol next to ZBI-Preferences.

3.  Click on Saved Searches. 

Then, click on New Search.

Local Broadcast Search

Local broadcasts send a discovery request to the local broadcast address of 255.255.255.255. 
This request finds printers in the same local network as the requesting computer. The local 
broadcast search is the default search type used by the program. 

To create a local broadcast search, do the following:

1. In the Search Type dialog, select Local Broadcast. The Value fields are automatically 
populated.

2. Type a name in the Search Group Name textbox.

3. Click Add. The Value field is added to Search type. 

4. Click OK to accept the new Search Type.

5. Click OK to exit the Preferences dialog.
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Subnet Search

The Subnet Search sends a discovery request to each address in the specified subnet. This 
feature is useful for networks that prevent broadcast packets from passing across routers. The 
Subnet search requires you to type in the first three subnet octets. 

Example: A request to 192.168.2.* sends a request to: 192.168.2.1 through 192.168.2.254.

To create a Subnet Search, do the following:

1. From the Search Type dialog, select Subnet.

2. Type a name in the Search Group Name textbox.

3. n the Value field, type the first three subnet octets.

4. Click Add.

5. Click OK to accept the new Search Type.

6. Click OK to exit the Preferences dialog.

Directed Broadcast Search

Directed broadcasts send a discovery request to the broadcast address of the specified subnet.

Note • If a broadcast search does not work, the broadcast packets might be disabled across 
routers. Try Multicast or Subnet search.

Example • The directed broadcast search requires you to type in the first three subnet 
octets, followed by 255, such as 192.168.2.255. 

To create a Directed Broadcast search, do the following:

1. In the Search Type dialog, select Directed Broadcast. The fourth octet of the Value field is 
automatically populated. 

2. In the Value field, type the first three subnet octets.

3. Type a name in the Search Group Name textbox.

4. Click Add. 

5. Click OK to accept the new Search Type.

6. Click OK to exit the Preferences dialog.
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Multicast Search

Multicast uses the multicast address to send a discovery address to all Zebra printers across as 
many routers as the hop count specifies. A multicast search may return a large number of 
printers in some installations.

This feature might be disabled on some routers and switches. See your network administrator 
to determine if a search failure was due to this feature being disabled. 

To create a multicast search, do the following:  

1. In the Search Type dialog, select Multicast (Hops). 

2. In the Value field, type the number of hops desired. The recommended starting point is 5

3. Type a name in the Search Group Name textbox.

4. Click Add. 

5. Click OK to accept the new Search Type.

6. Click OK to exit the Preferences dialog.

IP Address Search

To create a search for an IP address, do the following:  

1. In the Search Type dialog, select IP Address xxx.xxx.xxx.xxx.

Example • Type in an IP address, such as 10.3.4.97.

2. In the Value field type in an IP address.

3. Type a name in the Search Group Name textbox.

4. Click Add. 

5. Click OK to accept the new Search Type.

6. Click OK to exit the Preferences dialog.

Using a Printer via the Serial Port

If a printer is connected to the PC via the RS-232 Serial port, it is possible to use the 
Debugging features of ZBI-Developer, by making use of the Virtual Printer system.

Using a Printer via the Parallel Port

If a printer is connected to the PC via the Parallel Port, it is possible to use the Debugging 
features of ZBI-Developer, by making use of the Virtual Printer system.
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Using Virtual Printers

ZBI-Developer offers the ability to execute a ZBI program on the PC with no printer required. 
The Virtual Printer system makes it possible for the user to control the inputs and view the 
output of their program – all without having a printer attached to the computer. 

Additionally, the Virtual Printer system makes it possible to connect devices to the PCs’ RS-
232 Serial or Parallel ports and direct input from those ports into their program. For example, 
if the ZBI program being written will need to accept data from coming into the printer via the 
RS-232 Serial port from a weigh scale, that event could be simulated by attaching the weigh 
scale to the PC and configuring the Virtual Printer to accept data from the computers serial 
port. 

Next, if a printer is available, but it not yet ZBI-Enabled, the Virtual Printer system allows the 
output of the ZBI program to be sent to the computers parallel or serial ports to a printer. For 
example, a ZBI program could be written to send output to the printer label formatting engine 
– while the Virtual Printer is configured to take that same data and redirect it to the computers 
serial port to a printer attached to that port. In this way, the label formatting commands that are 
frequently the output of many ZBI program can be tested, even if a ZBI-Enabled printer is not 
immediately available.

Edit a Virtual Printer

Virtual Printers can be edited to alter their settings. To Edit a Virtual Printer, right-click 
over the Virtual Printer in the Printers View and select Edit Virtual Printer.

The Edit Virtual Printer Wizard will display.
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Configure where output from the Virtual Printers ports should be directed. For this Tutorial, 
leave all of the Ports set to Comm Window.

Note • Virtual Printers can be used to examine the output of a ZBI program. They do not 
have the ability to create an image of a printed label based on the receipt of printer 
commands. That capability is only present in the printer. 
1/17/08 ZBI-Developer User Guide 48789L-001 Rev. A



ZBI-Developer
ZBI-Developer Tutorial

68
Creating a Debug Connection

Once the printer to be used has been Discovered, or a Virtual Printer has been selected and 
configured, the next step is to run your program through the debugger environment. 

ZBI-Developer offers several advanced features that allow the programmer to test the logic 
and flow of a program before it is deployed. Key features are the ability to:

• Set and view breakpoints

• View the data contained in variables as a program is running

• Input and view the data being sent to Ports defined in the ZBI program

• Pause, Run or Terminate the Debugging mode as needed. 

Once the printer type to be used has been determine (Virtual Printer or a networked printer) it 
is necessary to create a debug connection to the printer.

In all cases, Creating a Debug Connection is done in the following way – navigate to the 
Printer View Tab, right-click over the desired printer and choose Create Debug Connection. 
For the purposes of this tutorial, select a virtual printer. 
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After the debug connection has been made, the debug connection icon will appear next to the 
selected printer.

Note • Once a debug connection has been made to a printer, ZBI-Developer will attempt 
to maintain that connection, even if the program is shut down and re-started. Upon 
restarting, ZBI-Developer will attempt to reconnect to the selected printer.

Note • Only ZBI-Enabled printers running firmware v60.16.x, v53.16.x or later support 
on-printer debugging. If you do not have a printer that meets this requirement, contact 
your reseller. For the purpose of this Tutorial, it is also possible to use a Virtual Printer if a 
ZBI-Enabled printer is not available, but a ZPL printer is.
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Debug a Program

Once the necessary Breakpoints have been created and a Debug Connection has been made, 
the program can be run.

Note • For the purposes of this Tutorial, the program will be run in the Virtual Printer 
environment, with output initially directed to the computer’s screen instead of to a printer.

The first step is to change the Perspective from the ZBI Perspective to the Debug 
Perspective. Click on Window > Show Perspective > Debug Perspective or click the  
icon to change the perspective. 
48789L-001 Rev. A ZBI-Developer User Guide 1/17/08



71ZBI-Developer
ZBI-Developer Tutorial
Changing the Screen Layout

The initial screen layout may be appropriate for some Debugging sessions, however the layout 
can also be changed to maximize the ability to see the various important Views that can be 
used while Debugging a program. 

For this Tutorial, the Variable View, Serial Comm Window View and ZPL Comm Window 
View will be moved to make them all visible at the same time. To move a View, click and drag 
it to a new location. While a View is being moved, an outline of the View will be visible. 
Rearrange the Debug Perspective so that it looks like this:
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Run a Program

To run the program you’ve just written, click on menu Run > Run/Debug Program or click 
the  icon. 

Notice that several things have changed on the screen. 

• The program has executed to line 40 and is now awaiting input. 

• A data entry prompt is now displayed in the Serial and ZPL Views

• The icons in the Debug View have changed so that the Terminate  and Pause  
icons are now active. Do not click these yet!

To test the program, type "Hello" into the data entry prompt in the Serial View and click Send; 
this simulates data coming into the printer via the RS-232 serial port. 
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Notice the changes on the screen. 

• The A$ variable has been filled with the data you sent via the serial port.

• The ZPL Port View has been filled with the ZPL command from Line 50 of the program. 
This is the output of the program. If the program was being run on a printer, or if the 
Virtual Printer was configured to direct the ZPL out to a printer connected to the PC, this 
is what the printer would use to print a label. 

• The Resume  and Step Over  icons are now active in the Debug View

• Line 60 of the program is Highlighted, showing the line the program has stopped on – 
because of the Breakpoint.
1/17/08 ZBI-Developer User Guide 48789L-001 Rev. A



ZBI-Developer
ZBI-Developer Tutorial

74
Step Over a Breakpoint

Now that the program is at a Breakpoint, you can Step Over the breakpoint and allow the 
program to execute to its next logical step. Click on the Step Over icon  and note that 
program has executed to Line 40, again looking for input into the serial port. 
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Type "Print Me" in the data entry prompt in the Serial Port View and click Send; this 
simulates data coming into the printer via the RS-232 serial port.

Note • The program is still on Line 40.

Click the Step Over Icon again to move the new data into the Variable View.
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Next, click the Step Over icon again to move the program to the next step – embedding "Print 
Me" into the ZPL defined on Line 50.

Note • A new line of ZPL is shown in the ZPL Port View.

Terminating a Running Program

To stop a running program, click on the Terminate  icon in the Debug View. Any active 
Port Views will be deactivated and defaulted. The last value stored in the variable will remain 
in the Variables View. The Step Over, Terminate and Resume icons in the Debug View will be 
deactivated. If the program was being debugged on a printer instead of in a Virtual Printer, it 
will be stopped. 
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Creating the Autoexec.zpl file

ZBI-Developer can automatically create an Autoexec.zpl file for use with the program being 
created. 

An Autoexec.zpl file is used to cause the printer to automatically run a set of commands when 
the printer is first powered up. In the context of a ZBI program, the Autoexec.zpl file can cause 
the program to be executed when the printer is turned on.

Note • ZBI-Developer creates an Autoexec.zpl file that addresses only the need to start a 
selected ZBI program. If the user requires that the Autoexec.zpl file perform additional 
functions, the file will require editing to include those functions.

To create an Autoexec.zpl file, right-click over a .zbi file in a Project and select Generate 
Autoexec.zpl. The Autoexec Wizard will display. Name the file and select the Console and 
Local Echo options as needed. Consult the ZPL manual for details on how to use these 
options. 
1/17/08 ZBI-Developer User Guide 48789L-001 Rev. A



ZBI-Developer
ZBI-Developer Tutorial

78
Sending Files to Printers

When the software has been connected to a networked printer, ZBI-Developer can send 
individual files or an entire project to a printer. See the information on Creating a Debug 
Connection on page 68 for details on how to connect to a networked printer.

To send a file to a printer once a Debug connection has been made, right-click over the file and 
choose Send to Printer. 

To send the contents of the entire project to the printer, right-click over the Project folder and 
choose Send to Printer.

Note • Use ZebraNet Bridge to send files to printers via the Serial, Parallel, or USB 
connections.
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Import ZBI Files From a Printer

When the software has been connected to a networked printer, ZBI-Developer can retrieve 
ZBI programs from a printer. See the information on Creating a Debug Connection on page 68 
for details on how to connect to a printer.

To retrieve ZBI programs from a printer, right-click over the printer and select Import File.

The Import Wizard will display. Select the file(s) to import from the printer to the PC and then 
the Project to import the file(s) into. Click Finish to complete the Wizard.

Note • Encrypted ZBI programs (with a .bae extension) cannot be imported from the 
printer back to ZBI-Developer. It is recommended that you archive Encrypted ZBI 
programs.
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Compare or Replace Files
ZBI-Developer maintains a log of file changes, making it possible to compare or replace the 
current version of a file with prior versions. This feature can be very useful when iterative 
changes are being made to a program. 

To use the Compare feature, right-click over a file and select Compare With > Local 
History. The Compare with Local History dialog will be displayed. If a file has gone through 
multiple changes and saves, each of those event will be available to select for comparison with 
the current version. By selecting Replace With > Local Version it is possible to choose an 
earlier version of the file to replace the current version. 

Additionally, two files can be compared with each other. To compare two files, hold down the 
Ctrl on the keyboard and select two files. Then right-click over one of the files and choose 
Compare With > Each Other.
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Encryption of ZBI Programs
This section details how to optionally encrypt programs before distributing them.

Note • It is recommended that Projects and Project files be backed up on a regular basis. 
Zebra Technologies and ZBI-Developer do not automatically back-up files or offer a 
method for un-encrypting programs. 

ZBI-Developer can encrypt ZBI programs for use on printers that support ZBI 2.0 and above. 
The purpose of this feature is to allow the programmer to protect the source code of the 
program once it has been deployed to printers. Programs that have been encrypted are 
represented in the ZBI-Developer environment with the “encrypted ZBI program” icon  
instead of the standard ZBI program icon . 

Note • The Encryption Key and the source code for ZBI programs should be regularly 
archived. 

While the encrypted program will remain in plain text in the ZBI-Developer environment, it 
will be encrypted and MIME encoded when it is sent to the printer.

The Default Encryption Key 

ZBI-Developer has a unique encryption key that is created when the program is installed. This 
key is the default key used when a ZBI program is encrypted – unless another key has been 
created. 

Note • It is recommended that the Default Encryption Key be used rather than creating 
additional keys. This approach is recommended to make the task of managing the keys 
easier over time. 

Encryption keys can be shared between users in one of two ways:

• The key file can be copied from one machine to another. This approach is recommended 
when program development and encryption will be done from remote locations. 

• The key file can be stored on a networked drive, made available to any of the 
programmers to use. 
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Encrypt a ZBI Program 

To encrypt a ZBI program, right-click over the program and choose Encrypt ZBI Program. 
The program will display a Warning dialog as shown below:

Next, the program will offer the choice to use the Default Encryption Key or to Generate a 
New Key. 

Note • It is recommended that the Default Encryption Key be used rather than creating 
additional keys. This approach is recommended to make the task of managing the keys 
easier over time.
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Choose which Key to use and click Finish to complete the Encryption Key Wizard. The ZBI 
program will be marked as encrypted. When it is sent to a ZBI 2.0 printer, it will be encrypted 
and MIME encoded.

Example • The program from the ZBI-Developer tutorial is shown below in plain text 
form:

10 close all

20 open #1: name "SER"

30 open #2: name "ZPL"

40 input #1: A$

50 print #2: "^xa^fo50,50^a0n,50,50^fd"&A$&"^fs^xz"

60 goto 40

When encrypted and sent to the printer, the program is transmitted in the following format:

^XA^IDE:HELLO.BAS^XZ^XA^IDE:HELLO.BAE^XZ^XA^IDR:HELLO.
BAS^XZ^XA^IDR:HELLO.BAE^XZ~DZE:HELLO.BAE,176,:B64:SEVM
TE8AAAAAACUAAAAAoPDiWDoW22sG86Nnf7HUfLZB3YSMil9HwPcpzI
Ms4buW+FDGw2FY89osEEofNF9euU8dz5872jW8Gafq85vsr47SydHG
IjymIVxQq6c50GRBJjFrEVkh+uvhnHWQ7HRasXvB7N/
VfB0qKSDiICdwzNkRZL5G3nFAQFIQtfDyrv51IBYfGRn+4lxHcPRUG
NveleNcSP58qjt+UBXziVVLlv0=:61b3
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Distributing Encrypted Programs

When an Encrypted ZBI 2.0 program is distributed to a printer, they program will appear on 
the printers directory listing page with the extension “.bae” (basic encrypted). The file will 
be listed in on the printer’s directory listing page, but it will not be possible to return the 
program to the host in plain text format.

Note • The program will not run unless the encryption key has been sent to the printer. To 
send the encryption key to the printer, right click over the key and click “Send to Printer”. 
The key can also be exported out of ZBI-Developer to a file on the computers hard drive – 
and then that exported file can be sent to printers as needed. Zebra does recommend 
maintaining control over access to the Encryption key in order to benefit from the 
protection the Encryption system offers.

Generate a New Key 

The default encryption key is the recommended key to use, however it may be desirable to 
create a new key. For example, a developer may want to create a new key for a unique project. 
A new encryption key can be created when the user chooses to encrypt the program. 

To create a new key, select “Generate New Key” when encrypting a program. A new unique 
key will be created and displayed in the Project folder with the Key  icon.

Key Storage

Note •  It is recommended that Projects and Project files be backed up on a regular basis. 
ZBI-Developer does not automatically back-up files or offer a method for un-encrypting 
programs if the Encryption Key is not present.

ZBI File Properties

The properties for each ZBI file can be viewed and set by right-clicking over a ZBI file and 
choosing Properties. The file size, location, encoding type and other settings are displayed on 
the Info dialog. Additionally, the file attributes can be set on the “ZBI Options Info Page”. 

Note • Setting the attributes for a ZBI program will change how it is presented on the 
printers web pages. If a file is configured to be persistent, it can only be deleted if it is 
specifically named in a command. For example, if a persistent file is named 
“hello.bae” was stored in E memory, the ZPL command to delete it would be 
“^XA^IDE:Hello.bae^FS^XZ”.
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ZBI Technical Support

Online Support

You can find the latest builds and updates under the Support section on the Zebra Web site. 

If you cannot resolve the issue, please contact your local reseller or the offices listed in 
Contact Information.

Contact Information

Worldwide, Technical Support is available through your Reseller, or at:  
http://www.zebra.com/support.

Professional ZBI Programming services can be obtained by contacting:

zbi-experts@zebra.com

Service Quotations available upon request.

Zebra Technologies Corporation 
International Headquarters 
333 Corporate Woods Parkway 
Vernon Hills, Illinois 60061-3109 USA

Phone: +1 847 913 2259 
Fax: +1 847 913 2578
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End User License 
Agreement

Please read the terms of this “End User License Agreement” (the “Agreement”) carefully. The 
Agreement is a legal agreement between you (either an individual or a single entity) and Zebra 
Technologies International, LLC (“Zebra”) for the Zebra computer software and/or firmware 
accompanying this End User License Agreement, and any associated media, printed materials 
and any “online” or electronic documentation (collectively, “Software”). By installing or using 
the Software, you agree to be bound by the terms of this Agreement. If you do not agree to the 
terms of this Agreement, you may not install or use the Software. 

1.  Grant of License.   The Software is protected by copyright and other intellectual 
property laws and international treaties. The Software is licensed to you, and not sold, subject 
to the terms of this Agreement. Subject to the terms of this Agreement, Zebra hereby grants 
you a limited, personal, non-exclusive license during the term of this Agreement to use the 
Software solely and exclusively for your internal use for the operation of your associated 
Zebra printer(s) and for no other purpose. To the extent that any portion of the Software is 
provided to you in a manner that is designed to be installed by you, you may install one copy 
of the installable Software on one hard disk or other storage device for one printer, computer, 
workstation, terminal, or other digital electronic device, as applicable (an “Electronic 
Device”), and you may access and use that Software as installed on that Electronic Device so 
long as only one copy of such Software is in operation. If you are an organization rather than 
an individual, you may authorize personnel associated with your business to use the Software, 
but only one person at a time on one Electronic Device at a time. You agree not to duplicate or 
copy the Software, except that you may make one back-up copy for archive purposes. The 
primary user of the Electronic Device on which installable Software is installed may also make 
a copy for his or her exclusive use on a portable computer, so long as such Software is being 
used only on one Electronic Device at a time. 

2.  Storage/Network Use.  In the alternative, you may install a copy of the Software on a 
storage device, such as a network server, used only to access and use the Software on your 
Electronic Devices over an internal network; however, you must acquire and dedicate a license 
for each separate Electronic Device on which the Software is accessed and used from the 
storage device. A license for the Software may not be shared or used concurrently on different 
Electronic Devices. 
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3.  Documentation.  If the Software contains documentation which is provided only in 
electronic form, you may print one copy of such electronic documentation. You may not copy 
the printed materials accompanying the Software.

4.  Limitations of Reverse Engineering, Decompilation and Disassembly.  You 
may not reverse engineer, decompile, or disassemble the Software, except and only to the 
extent that such activity is permitted by applicable law notwithstanding this limitation.

5.  Transfer/Sublicense.  You may not transfer, sublicense, distribute, rent, lease, supply, 
market or lend the Software to any other party. 

6.  Confidentiality.  You acknowledge that the Software embodies confidential information 
owned by Zebra and/or its suppliers and licensors. To the extent you have access to any such 
information, you agree to use such information only for the authorized use of the Software. 
You further agree not to disclose such confidential information to any other party and to use at 
least the same degree of care to maintain the confidential nature of such information as you use 
to maintain the confidentiality of your own confidential information.

7.  Intellectual Property.  All title, copyrights and other intellectual property rights in and 
to the Software (including but not limited to copyrights, patents, trade secrets and trademarks) 
are owned by Zebra or its suppliers and licensors. You must maintain all copyright notices on 
all copies of the Software. All rights not expressly granted are reserved by Zebra. Without 
prejudice to any rights or remedies Zebra may have for your violation of this Software 
License, Zebra shall own all changes or modifications to the Software. 

8.  Termination.  Without prejudice to any other rights or remedies Zebra may have, Zebra 
may terminate this Agreement if you fail to comply with the terms and conditions of this 
Agreement. Zebra may terminate this Agreement by offering you a superseding Agreement for 
the Software or any replacement or modified version of or upgrade to the Software and 
conditioning your continued use of the Software or such replacement, modified or upgraded 
version on your acceptance of such superseding Agreement. In addition, either party may 
terminate this Agreement at any time. Subject to the foregoing, termination shall be effective 
upon notice to the other party. In the event that this Agreement terminates for any reason, your 
license to use the Software will terminate, and you must immediately stop using the Software, 
destroy all copies of the Software and all of its component parts, and, upon request, provide an 
affidavit certifying your compliance with the foregoing. The provisions of Sections 4, 5, 6, 7, 
12, 13, 14, 15, 16, 17, 18, 19 and 20 shall survive termination of this Agreement.

9.  U.S. Government Restricted Rights.  All Software provided to the U.S. Government 
pursuant to solicitations issued on or after December 1, 1995 is provided with the commercial 
rights and restrictions described elsewhere herein. All Software provided to the U.S. 
Government pursuant to solicitations issued prior to December 1, 1995 is provided with 
RESTRICTED RIGHTS as provided for in FAR, 48 CFR 52.227-19 (JUNE 1987) or DFARs, 
48 CFR 252.227-7013 (OCT 1988), as applicable.
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10.  Export Restrictions.  You agree that you will not export or re-export the Software, any 
part thereof, or any process or service that is the direct product of the Software (the foregoing 
collectively referred to as the “Restricted Components”), to any country, person or entity 
subject to U.S. export restrictions. You specifically agree not to export or re-export any of the 
Restricted Components: (i) to any country to which the U.S. has embargoed or restricted the 
export of goods or services, which currently include but are not necessarily limited to Cuba, 
Iran, Iraq, North Korea, Sudan and Syria, or to any national of any such country, wherever 
located, who intends to transmit or transport the Restricted Components back to such country; 
(ii) to any person or entity who you know or have reason to know will utilize the Restricted 
Components in the design, development or production of nuclear, chemical or biological 
weapons; or (iii) to any person or entity who has been prohibited from participating in U.S. 
export transactions by any federal agency of the U.S. government. You warrant and represent 
that neither the U.S. Commerce Department, Bureau of Export Administration nor any other 
U.S. federal agency has suspended, revoked or denied your export privileges. 
Contractor/Manufacturer is Zebra Technologies Corporation, 333 Corporate Woods Parkway, 
Vernon Hills, Illinois 60061. 

11.  Accessing Services Using the Software.  Your use of any service accessible using 
the Software is not covered by this EULA and may be governed by separate terms of use, 
conditions or notices. Zebra and its suppliers and licensors hereby disclaim any such liability 
for any such services accessed.

12.  Disclaimer.  ZEBRA SUPPLIES THE SOFTWARE AS IS AND WITH ALL FAULTS 
AND DOES NOT MAKE ANY WARRANTIES WHATSOEVER, EXPRESS OR IMPLIED, 
INCLUDING BUT NOT LIMITED TO WARRANTIES CONCERNING THE SOFTWARE 
OR ANY APPLICATION, OPERATION OR USE THEREOF, THE OUTPUT OR THE 
DATA GENERATED BY THE OPERATION OR USE THEREOF, OR ANY SUPPORT 
SERVICES RENDERED WITH RESPECT THERETO. ZEBRA HEREBY EXCLUDES 
ALL IMPLIED WARRANTIES TO THE MAXIMUM EXTENT AUTHORIZED BY LAW, 
INCLUDING, SPECIFICALLY, ANY IMPLIED WARRANTY ARISING BY STATUTE OR 
OTHERWISE IN LAW OR FROM A COURSE OF DEALING OR USAGE OF TRADE, 
ALL IMPLIED WARRANTIES OF MERCHANTABILITY, OR OF MERCHANTABLE 
QUALITY, OR OF FITNESS FOR ANY PURPOSE, PARTICULAR, SPECIFIC OR 
OTHERWISE, OR OF TITLE, OR OF NONINFRINGEMENT. SOME JURISDICTIONS 
DO NOT ALLOW THE EXCLUSION OR LIMITATION OF IMPLIED WARRANTIES, SO 
THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU. WHEN THE 
IMPLIED WARRANTIES ARE NOT ALLOWED TO BE EXCLUDED IN THEIR 
ENTIRETY, THEY WILL BE LIMITED TO THE DURATION OF NINETY (90) DAYS. 
WITHOUT LIMITING THE GENERALITY OF THE FOREGOING, ZEBRA DOES NOT 
WARRANT THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED 
OR ERROR FREE. To the extent that the Software covered by this EULA includes emulation 
libraries, such emulation libraries do not work 100% correctly or cover 100% of the 
functionality of the printer language being emulated, are offered “as is” AND WITH ALL 
FAULTS, AND ALL THE DISCLAIMERS AND LIMITATIONS CONTAINED IN THIS 
PARAGRAPH AND THIS AGREEMENT APPLY TO SUCH EMULATION LIBRARIES. 
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13.  Limitation of Liability and Damages.  ZEBRA DOES NOT ASSUME 
RESPONSIBILITY FOR ANY SPECIFIC APPLICATION OF THE SOFTWARE OR FOR 
COMPATIBILITY WITH OTHER SOFTWARE OR EQUIPMENT. TO THE FULL 
EXTENT ALLOWED BY LAW, ZEBRA EXCLUDES FOR ITSELF AND ITS LICENSORS 
AND SUPPLIERS ANY LIABILITY FOR ANY DAMAGES, INCLUDING WITHOUT 
LIMITATION DIRECT, CONSEQUENTIAL, INCIDENTAL, INDIRECT, SPECIAL, 
EXEMPLARY OR PUNITIVE DAMAGES OF ANY KIND, OR FOR LOSS OF REVENUE 
OR PROFITS, LOSS OF BUSINESS, DAMAGE TO GOODWILL, LOSS OF 
INFORMATION OR DATA, OR OTHER FINANCIAL LOSS ARISING OUT OF OR IN 
CONNECTION WITH THE SALE, INSTALLATION, MAINTENANCE, USE, 
PERFORMANCE, FAILURE, OR INTERRUPTION OF ANY PRODUCTS, PARTS OR 
SOFTWARE, WHETHER BASED ON CONTRACT, TORT, NEGLIGENCE, STRICT 
LIABILITY OR OTHERWISE, EVEN IF ZEBRA OR ANY LICENSOR OR SUPPLIER 
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. TO THE 
MAXIMUM EXTENT AUTHORIZED BY LAW, THIS DISCLAIMER OF LIABILITY 
FOR DAMAGES WILL NOT BE AFFECTED IF ANY REMEDY PROVIDED HEREIN 
SHALL FAIL OF ITS ESSENTIAL PURPOSE. SOME JURISDICTIONS DO NOT ALLOW 
THE EXCLUSION OR LIMITATION OF DIRECT, INCIDENTAL, CONSEQUENTIAL OR 
OTHER DAMAGES, SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY 
TO YOU. WHEN LIABILITY FOR DAMAGES IS NOT ALLOWED TO BE LIMITED OR 
EXCLUDED IN ITS ENTIRETY, ZEBRA LIMITS ITS LIABILITY TO REPAIR, 
REPLACEMENT, OR, AT ZEBRA'S OPTION, REFUND OF THE PRICE OF THE 
SOFTWARE.

14.  Zebra Suppliers and Licensors.  Any release, disclaimer or limitation of Zebra's 
liability or damages pursuant to this Agreement shall be construed, in addition to Zebra's 
benefit, also to the benefit of Zebra's suppliers, licensors, employees, and contractors and, 
without limiting any other defenses that such suppliers, licensors, employees and contractors 
may have, you agree to release such parties from liability or damages in accordance with such 
release, disclaimer, or limitation of liability or damages to the same extent that such provisions 
apply to Zebra. 

15.  Governing Law.  To the maximum extent permitted by law, the laws of the State of 
Illinois, U.S.A., without reference to its conflict of laws provisions, will apply to this 
Agreement. You irrevocably agree to submit to the exclusive jurisdiction and venue of the 
state or federal courts in the State of Illinois in the event of any litigation involving this 
Agreement or the Software. You agree that you shall not assert any claim that you are not 
subject to the jurisdiction of such courts, that the venue is improper, that the forum is 
inconvenient or any similar objection, claim or argument. Zebra may, in its sole discretion, 
choose to resolve any controversy or dispute between you and Zebra concerning this 
Agreement, or the existence, validity, breach or termination thereof, whether during or after 
the term by binding arbitration in accordance with the Commercial Arbitration Rules of the 
American Arbitration Association (“AAA”), as modified or supplemented under this Section 
15, by providing notice to you. In the event that Zebra provides such notice, you hereby waive 
any right to institute a court or other dispute resolution proceeding with respect to such 
controversy or dispute and acknowledge arbitration in accordance with this Section 15 as the 
sole and exclusive means of resolving such controversy or dispute. The arbitration proceeding 
will take place in Chicago, Illinois and be conducted in the English language. The arbitration 
panel will consist of 3 arbitrators, one arbitrator appointed by each party and a third neutral 
arbitrator appointed by the two arbitrators designated by the parties. Any communication 
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between a party and any arbitrator will be directed to the AAA for transmittal to the arbitrator. 
The parties expressly agree that the arbitrators will be empowered to, at either party’s request, 
grant injunctive relief. The arbitral award will be the exclusive remedy of the parties for all 
claims, counterclaims, issues or accountings presented or pleaded to the arbitrators. Judgment 
upon the arbitral award may be entered in any court that has jurisdiction thereof. Any 
additional costs, fees or expenses incurred in enforcing the arbitral award will be charged 
against the party that resists its enforcement. Nothing in this Section will prevent Zebra from 
seeking interim injunctive relief against you or filing an action against you to collect unpaid 
and past due amounts in any court of competent jurisdiction.

16.  Injunctive Relief.  You acknowledge that, in the event you breach any provision of this 
Agreement, Zebra will not have an adequate remedy in money or damages. Zebra shall 
therefore be entitled to obtain an injunction against such breach from any court of competent 
jurisdiction immediately upon request without posting bond. Zebra's right to obtain injunctive 
relief shall not limit its right to seek further remedies.

17.  Entire Agreement.  This Agreement constitutes the entire understanding and 
agreement of the parties and supersedes any and all prior or contemporaneous representations, 
understandings and agreements between the parties with respect to the subject matter of this 
Agreement. If any provision of this Agreement is held invalid, the remainder of this 
Agreement shall continue in full force and effect.

18.  Assignment.  You may not assign this Agreement or any of your rights or obligations 
hereunder (by operation of law or otherwise) without the prior written consent of Zebra. Zebra 
may assign this Agreement and its rights and obligations without your consent. Subject to the 
foregoing, this Agreement shall be binding upon and inure to the benefit of the parties to it and 
their respective legal representatives, successors and permitted assigns.

19.  Modification.  No modification of this Agreement shall be binding unless it is in writing 
and is signed by an authorized representative of the party against whom enforcement of the 
modification is sought.

20.  Waiver.  The failure by a party to exercise any right hereunder shall not operate as a 
waiver of such party's right to exercise such right or any other right in the future.

21.  QUESTIONS.  Should you have any questions, or if you desire to contact Zebra for any 
reason, please contact the Zebra subsidiary serving your country, or write:

Zebra Technologies International, LLC 
333 Corporate Woods Parkway 
Vernon Hills, Illinois 60061

Effective February 2006.  
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